CVE-2024-23320

High

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server. This issue is a legacy of CVE-2023-49299. We didn't fix it completely in CVE-2023-49299, and we added one more patch to fix it. This issue affects Apache DolphinScheduler: until 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Dolphinscheduler
PublishedFeb 23, 2024
First seenFeb 23, 2024

How to fix

Update
  • apache dolphinscheduler3.2.1 or later
  • org.apache.dolphinscheduler:dolphinscheduler-master3.2.1 or later

Affected products

ProductAffected versionsFixed in
apache dolphinschedulerv < 3.2.13.2.1
org.apache.dolphinscheduler:dolphinscheduler-masterMavenv < 3.2.13.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-23320 · Apache Dolphinscheduler · Dark Radar