CVE-2024-23321
Description
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
How to fix
- apache rocketmq5.3.0 or later
- org.apache.rocketmq:rocketmq-all5.3.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache rocketmq | 4.5.2 ≤ v < 5.3.0 | 5.3.0 |
| org.apache.rocketmq:rocketmq-allMaven | 4.5.2 ≤ v < 5.3.0 | 5.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.