CVE-2024-23349

Medium

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1. XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack. Users are recommended to upgrade to version [1.2.5], which fixes the issue.

SeverityMedium
CVSS5.4
Exploit probability—
ProductApache Answer
PublishedFeb 22, 2024
First seenFeb 22, 2024

How to fix

Update
  • github.com/apache/incubator-answer1.2.5 or later

Affected products

ProductAffected versionsFixed in
apache answerv ≤ 1.2.1—
github.com/apache/incubator-answerGov < 1.2.51.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.