CVE-2024-23635

Medium

Description

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductAntisamy
PublishedFeb 2, 2024
First seenFeb 2, 2024

How to fix

Update
  • antisamy_project antisamy1.7.5 or later
  • org.owasp.antisamy:antisamy1.7.5 or later

Affected products

ProductAffected versionsFixed in
antisamy_project antisamyv < 1.7.51.7.5
org.owasp.antisamy:antisamyMavenv < 1.7.51.7.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.