CVE-2024-23656
Description
Dex is an identity service that uses OpenID Connect to drive authentication for other apps. Dex 2.37.0 serves HTTPS with insecure TLS 1.0 and TLS 1.1. `cmd/dex/serve.go` line 425 seemingly sets TLS 1.2 as minimum version, but the whole `tlsConfig` is ignored after `TLS cert reloader` was introduced in v2.37.0. Configured cipher suites are not respected either. This issue is fixed in Dex 2.38.0.
How to fix
- github.com/dexidp/dex2.38.0, 0.0.0-20240125115555-5bbdb4420254 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linuxfoundation dex | 2.37.0 | — |
| github.com/dexidp/dexGo | 2.37.0 ≤ v < 2.38.0, v < 0.0.0-20240125115555-5bbdb4420254, No range specified | 2.38.0, 0.0.0-20240125115555-5bbdb4420254 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.