CVE-2024-23672
Description
Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
How to fix
- apache tomcat8.5.99, 9.0.86, 10.1.19 or later
- org.apache.tomcat:tomcat-websocket11.0.0-M17, 10.1.19, 9.0.86, 8.5.99 or later
- org.apache.tomcat.embed:tomcat-embed-websocket11.0.0-M17, 10.1.19, 9.0.86, 8.5.99 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 8.5.0 ≤ v < 8.5.99, 9.0.0 ≤ v < 9.0.86, 10.1.0 ≤ v < 10.1.19, 11.0.0 | 8.5.99, 9.0.86, 10.1.19 |
| debian debian_linux | 10.0 | — |
| fedoraproject fedora | 39, 40 | — |
| org.apache.tomcat:tomcat-websocketMaven | 11.0.0-M1 ≤ v < 11.0.0-M17, 10.1.0-M1 ≤ v < 10.1.19, 9.0.0-M1 ≤ v < 9.0.86, 8.5.0 ≤ v < 8.5.99 | 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99 |
| org.apache.tomcat.embed:tomcat-embed-websocketMaven | 11.0.0-M1 ≤ v < 11.0.0-M17, 10.1.0-M1 ≤ v < 10.1.19, 9.0.0-M1 ≤ v < 9.0.86, 8.5.0 ≤ v < 8.5.99 | 11.0.0-M17, 10.1.19, 9.0.86, 8.5.99 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.