CVE-2024-23831
Description
LedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.
How to fix
- ledgersmb ledgersmb1.10.30, 1.11.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ledgersmb ledgersmb | 1.3.0 ≤ v < 1.10.30, 1.11.0 ≤ v < 1.11.9 | 1.10.30, 1.11.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.