CVE-2024-23834

Medium

Description

Discourse is an open-source discussion platform. Improperly sanitized user input could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. The vulnerability is patched in 3.1.5 and 3.2.0.beta5. As a workaround, ensure Content Security Policy is enabled and does not include `unsafe-inline`.

SeverityMedium
CVSS6.3
Exploit probability—
ProductDiscourse
PublishedJan 30, 2024
First seenJan 30, 2024

How to fix

Update
  • discourse discourse3.1.5, 3.2.0 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.1.5, v < 3.2.0, 3.2.03.1.5, 3.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.