CVE-2024-23841

High

Description

apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.

SeverityHigh
CVSS8.2
Exploit probability—
ProductApollographql Apollo Client
PublishedJan 30, 2024
First seenJan 30, 2024
Weakness typeCWE-80CWE-80

How to fix

Update
  • apollographql apollo_client0.7.0 or later
  • @apollo/experimental-nextjs-app-support0.7.0 or later

Affected products

ProductAffected versionsFixed in
apollographql apollo_clientv < 0.7.00.7.0
@apollo/experimental-nextjs-app-supportnpmv < 0.7.00.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-23841 · Apollographql Apollo Client · Dark Radar