CVE-2024-24569

Medium

Description

The Pixee Java Code Security Toolkit is a set of security APIs meant to help secure Java code. `ZipSecurity#isBelowCurrentDirectory` is vulnerable to a partial-path traversal bypass. To be vulnerable to the bypass, the application must use toolkit version <=1.1.1, use ZipSecurity as a guard against path traversal, and have an exploit path. Although the control still protects attackers from escaping the application path into higher level directories (e.g., /etc/), it will allow "escaping" into sibling paths. For example, if your running path is /my/app/path you an attacker could navigate into /my/app/path-something-else. This vulnerability is patched in 1.1.2.

SeverityMedium
CVSS5.4
Exploit probability—
ProductPixee Java Code Security Toolkit
PublishedFeb 1, 2024
First seenFeb 1, 2024

How to fix

Update
  • pixee java_code_security_toolkit1.1.2 or later

Affected products

ProductAffected versionsFixed in
pixee java_code_security_toolkitv < 1.1.21.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.