CVE-2024-24574
Medium
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.
SeverityMedium
CVSS6.5
Exploit probability—
ProductPhpmyfaq
PublishedFeb 5, 2024
First seenFeb 5, 2024
Weakness typeCWE-79Cross-site scripting (XSS)CWE-80CWE-80
How to fix
Update
- phpmyfaq phpmyfaq3.2.5 or later
- phpmyfaq/phpmyfaq3.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpmyfaq phpmyfaq | v < 3.2.5 | 3.2.5 |
| phpmyfaq/phpmyfaqPackagist | v < 3.2.5 | 3.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.