CVE-2024-2469
High
Description
An attacker with an Administrator role in GitHub Enterprise Server could gain SSH root access via remote code execution. This vulnerability affected GitHub Enterprise Server version 3.8.0 and above and was fixed in version 3.8.17, 3.9.12, 3.10.9, 3.11.7 and 3.12.1. This vulnerability was reported via the GitHub Bug Bounty program.
SeverityHigh
CVSS8.0
Exploit probability—
ProductGithub Enterprise Server
PublishedMar 20, 2024
First seenMar 20, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- github enterprise_server3.8.17, 3.9.12, 3.10.9, 3.11.7, 3.12.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.8.17, 3.9.0 ≤ v < 3.9.12, 3.10.0 ≤ v < 3.10.9, 3.11.0 ≤ v < 3.11.7, 3.12.0 ≤ v < 3.12.1 | 3.8.17, 3.9.12, 3.10.9, 3.11.7, 3.12.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.