CVE-2024-24746
High
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache NimBLE. Specially crafted GATT operation can cause infinite loop in GATT server leading to denial of service in Bluetooth stack or device. This issue affects Apache NimBLE: through 1.6.0. Users are recommended to upgrade to version 1.7.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Nimble
PublishedApr 6, 2024
First seenApr 6, 2024
Weakness typeCWE-835CWE-835
How to fix
Update
- apache nimble1.7.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nimble | v < 1.7.0 | 1.7.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.