CVE-2024-24772
Medium
Description
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Apache Superset
PublishedFeb 28, 2024
First seenFeb 28, 2024
Weakness typeCWE-89SQL injection
How to fix
Update
- apache superset3.0.4, 3.1.1 or later
- apache-superset3.0.4, 3.1.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 3.0.4, 3.1.0 ≤ v < 3.1.1 | 3.0.4, 3.1.1 |
| apache-supersetPyPI | v < 3.0.4, 3.1.0 ≤ v < 3.1.1 | 3.0.4, 3.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.