CVE-2024-24812
Description
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known workarounds are available.
How to fix
- frappe frappe14.59.0, 15.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| frappe frappe | v < 14.59.0, 15.0.0 ≤ v < 15.5.0 | 14.59.0, 15.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.