CVE-2024-25141
Critical
Description
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache-airflow-providers-mongo
PublishedFeb 20, 2024
First seenFeb 20, 2024
Weakness typeCWE-295CWE-295
How to fix
Update
- apache apache-airflow-providers-mongo4.0.0 or later
- apache-airflow-providers-mongo4.0.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apache-airflow-providers-mongo | 1.0.0 ≤ v < 4.0.0 | 4.0.0 |
| apache-airflow-providers-mongoPyPI | v < 4.0.0 | 4.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.