CVE-2024-25640

Medium

Description

Iris is a web collaborative platform that helps incident responders share technical details during investigations. A stored Cross-Site Scripting (XSS) vulnerability has been identified in iris-web, affecting multiple locations in versions prior to v2.4.0. The vulnerability may allow an attacker to inject malicious scripts into the application, which could then be executed when a user visits the affected locations. This could lead to unauthorized access, data theft, or other related malicious activities. An attacker need to be authenticated on the application to exploit this vulnerability. The issue is fixed in version v2.4.0 of iris-web. No workarounds are available.

SeverityMedium
CVSS4.6
Exploit probability—
ProductIris
PublishedFeb 19, 2024
First seenFeb 19, 2024
Weakness typeCWE-87CWE-87

How to fix

Update
  • dfir-iris iris2.4.0 or later

Affected products

ProductAffected versionsFixed in
dfir-iris irisv < 2.4.02.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.