CVE-2024-25723
High
Description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
SeverityHigh
CVSS8.8
Exploit probability—
ProductZenml
PublishedFeb 27, 2024
First seenFeb 27, 2024
Weakness typeCWE-284Improper access control
How to fix
Update
- zenml zenml0.42.2, 0.44.4, 0.46.7 or later
- zenml0.42.2, 0.43.1, 0.46.7, 0.44.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| zenml zenml | v < 0.42.2, 0.44.0 ≤ v < 0.44.4, 0.45.0 ≤ v < 0.46.7, 0.43.0 | 0.42.2, 0.44.4, 0.46.7 |
| zenmlPyPI | v < 0.42.2, 0.43.0 ≤ v < 0.43.1, 0.45.0 ≤ v < 0.46.7, 0.44.0 ≤ v < 0.44.4 | 0.42.2, 0.43.1, 0.46.7, 0.44.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.