CVE-2024-26016
Description
A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.
How to fix
- apache superset3.0.4, 3.1.1 or later
- apache-superset3.0.4, 3.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 3.0.4, 3.1.0 ≤ v < 3.1.1 | 3.0.4, 3.1.1 |
| apache-supersetPyPI | v < 3.0.4, 3.1.0 ≤ v < 3.1.1 | 3.0.4, 3.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.