CVE-2024-26140
Medium
Description
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
SeverityMedium
CVSS4.6
Exploit probability—
ProductYetanalytics Lrs
PublishedFeb 20, 2024
First seenFeb 20, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- yetanalytics lrs1.2.17 or later
- yetanalytics sql_lrs0.7.5 or later
- com.yetanalytics:lrs1.2.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| yetanalytics lrs | v < 1.2.17 | 1.2.17 |
| yetanalytics sql_lrs | v < 0.7.5 | 0.7.5 |
| com.yetanalytics:lrsMaven | v < 1.2.17 | 1.2.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.