CVE-2024-26308
Medium
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.21 before 1.26. Users are recommended to upgrade to version 1.26, which fixes the issue.
SeverityMedium
CVSS5.5
Exploit probability—
Product
Apache Commons Compress
PublishedFeb 19, 2024
First seenFeb 19, 2024
Weakness typeCWE-770Allocation of resources without limits
How to fix
Update
- apache commons_compress1.26.0 or later
- org.apache.commons:commons-compress1.26.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache commons_compress | 1.21 ≤ v < 1.26.0 | 1.26.0 |
| org.apache.commons:commons-compressMaven | 1.21 ≤ v < 1.26.0 | 1.26.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.