CVE-2024-26580

Critical

Description

Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache Inlong
PublishedMar 6, 2024
First seenMar 6, 2024

How to fix

Update
  • apache inlong1.11.0 or later
  • org.apache.inlong:manager-common1.11.0 or later

Affected products

ProductAffected versionsFixed in
apache inlong1.4.0 ≤ v < 1.11.01.11.0
org.apache.inlong:manager-commonMaven1.8.0 ≤ v < 1.11.01.11.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.