CVE-2024-2660
Medium
Description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
SeverityMedium
CVSS6.4
Exploit probability—
Product
Hashicorp Vault
PublishedApr 4, 2024
First seenApr 4, 2024
Weakness typeCWE-636CWE-636
How to fix
Update
- hashicorp vault1.14.11, 1.16.0, 1.15.7 or later
- github.com/hashicorp/vault1.16.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp vault | 1.14.0 ≤ v < 1.14.11, 1.14.0 ≤ v < 1.16.0, 1.15.0 ≤ v < 1.15.7 | 1.14.11, 1.16.0, 1.15.7 |
| github.com/hashicorp/vaultGo | v < 1.16.0 | 1.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.