CVE-2024-27091
Description
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.
How to fix
- geosolutionsgroup geonode4.2.3 or later
- geonode4.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| geosolutionsgroup geonode | 3.2.0 < v < 4.2.3 | 4.2.3 |
| geonodePyPI | 3.2.1 ≤ v < 4.2.3 | 4.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.