CVE-2024-27136
Medium
Description
XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Apache Jspwiki
PublishedJun 24, 2024
First seenJun 24, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache jspwiki2.12.2 or later
- org.apache.jspwiki:jspwiki-main2.12.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache jspwiki | v < 2.12.2 | 2.12.2 |
| org.apache.jspwiki:jspwiki-mainMaven | v < 2.12.2 | 2.12.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.