CVE-2024-27285

Medium

Description

YARD is a Ruby Documentation tool. The "frames.html" file within the Yard Doc's generated documentation is vulnerable to Cross-Site Scripting (XSS) attacks due to inadequate sanitization of user input within the JavaScript segment of the "frames.erb" template file. This vulnerability is fixed in 0.9.36.

SeverityMedium
CVSS5.4
Exploit probability—
ProductYard
PublishedFeb 28, 2024
First seenFeb 28, 2024

How to fix

Update
  • yardoc yard0.9.36 or later

Affected products

ProductAffected versionsFixed in
yardoc yardv < 0.9.360.9.36
fedoraproject fedora38—
debian debian_linux10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.