CVE-2024-27292
High
Description
Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.
SeverityHigh
CVSS7.5
Exploit probability—
ProductJhpyle Docassemble
PublishedMar 21, 2024
First seenMar 21, 2024
Weakness typeCWE-706CWE-706
How to fix
Update
- jhpyle docassemble1.4.97 or later
- docassemble-webapp1.4.97 or later
- docassemble-base1.4.97 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jhpyle docassemble | 1.4.53 ≤ v < 1.4.97 | 1.4.97 |
| docassemble-webappPyPI | 1.4.53 ≤ v < 1.4.97 | 1.4.97 |
| docassemble-basePyPI | 1.4.53 ≤ v < 1.4.97 | 1.4.97 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.