CVE-2024-27307
Description
JSONata is a JSON query and transformation language. Starting in version 1.4.0 and prior to version 1.8.7 and 2.0.4, a malicious expression can use the transform operator to override properties on the `Object` constructor and prototype. This may lead to denial of service, remote code execution or other unexpected behavior in applications that evaluate user-provided JSONata expressions. This issue has been fixed in JSONata versions 1.8.7 and 2.0.4. Applications that evaluate user-provided expressions should update ASAP to prevent exploitation. As a workaround, one may apply the patch manually.
How to fix
- jsonata jsonata1.8.7, 2.0.4 or later
- jsonata1.8.7, 2.0.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jsonata jsonata | 1.4.0 ≤ v < 1.8.7, 2.0.0 ≤ v < 2.0.4 | 1.8.7, 2.0.4 |
| jsonatanpm | 1.4.0 ≤ v < 1.8.7, 2.0.0 ≤ v < 2.0.4 | 1.8.7, 2.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.