CVE-2024-27349
Critical
Description
Authentication Bypass by Spoofing vulnerability in Apache HugeGraph-Server.This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.3.0. Users are recommended to upgrade to version 1.3.0, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Hugegraph
PublishedApr 22, 2024
First seenApr 22, 2024
Weakness typeCWE-290CWE-290
How to fix
Update
- apache hugegraph1.3.0 or later
- org.apache.hugegraph:hugegraph-api1.3.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache hugegraph | 1.0.0 ≤ v < 1.3.0 | 1.3.0 |
| org.apache.hugegraph:hugegraph-apiMaven | 1.0.0 ≤ v < 1.3.0 | 1.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.