CVE-2024-27906

Medium

Description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

SeverityMedium
CVSS5.9
Exploit probability—
ProductApache Airflow
PublishedFeb 29, 2024
First seenFeb 29, 2024

How to fix

Update
  • apache airflow2.8.2 or later
  • apache-airflow2.8.2 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.8.22.8.2
apache-airflowPyPIv < 2.8.22.8.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.