CVE-2024-27915

Medium

Description

Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.

SeverityMedium
CVSS6.8
Exploit probability—
ProductSulu
PublishedMar 6, 2024
First seenMar 6, 2024

How to fix

Update
  • sulu sulu2.4.17, 2.5.13 or later
  • sulu/sulu2.4.17, 2.5.13 or later

Affected products

ProductAffected versionsFixed in
sulu sulu2.2.0 ≤ v < 2.4.17, 2.5.0 ≤ v < 2.5.132.4.17, 2.5.13
sulu/suluPackagist2.2.0 ≤ v < 2.4.17, 2.5.0-alpha1 ≤ v < 2.5.132.4.17, 2.5.13

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.