CVE-2024-28098

Medium

Description

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

SeverityMedium
CVSS6.4
Exploit probability—
ProductApache Pulsar
PublishedMar 12, 2024
First seenMar 12, 2024

How to fix

Update
  • apache pulsar2.10.6, 2.11.4, 3.0.3, 3.1.3 or later
  • org.apache.pulsar:pulsar-broker3.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6 or later

Affected products

ProductAffected versionsFixed in
apache pulsar2.7.1 ≤ v < 2.10.6, 2.11.0 ≤ v < 2.11.4, 3.0.0 ≤ v < 3.0.3, 3.1.0 ≤ v < 3.1.3, 3.2.02.10.6, 2.11.4, 3.0.3, 3.1.3
org.apache.pulsar:pulsar-brokerMaven3.2.0 ≤ v < 3.2.1, 3.1.0 ≤ v < 3.1.3, 3.0.0 ≤ v < 3.0.3, 2.11.0 ≤ v < 2.11.4, 2.7.1 ≤ v < 2.10.63.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.