CVE-2024-28103
Medium
Description
Action Pack is a framework for handling and responding to web requests. Since 6.1.0, the application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This vulnerability is fixed in 6.1.7.8, 7.0.8.2, and 7.1.3.3.
SeverityMedium
CVSS5.4
Exploit probability—
ProductRails
PublishedJun 4, 2024
First seenJun 4, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- rubyonrails rails6.1.7.8, 7.0.8.4, 7.1.3.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| rubyonrails rails | 6.1.0 ≤ v < 6.1.7.8, 7.0.0 ≤ v < 7.0.8.4, 7.1.0 ≤ v < 7.1.3.4, 7.2.0 | 6.1.7.8, 7.0.8.4, 7.1.3.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.