CVE-2024-28105

High

Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The category image upload function in phpmyfaq is vulnerable to manipulation of the `Content-type` and `lang` parameters, allowing attackers to upload malicious files with a .php extension, potentially leading to remote code execution (RCE) on the system. This vulnerability is fixed in 3.2.6.

SeverityHigh
CVSS7.2
Exploit probability—
ProductPhpmyfaq
PublishedMar 25, 2024
First seenMar 25, 2024

How to fix

Update
  • phpmyfaq/phpmyfaq3.2.6 or later

Affected products

ProductAffected versionsFixed in
phpmyfaq phpmyfaq3.2.5—
phpmyfaq/phpmyfaqPackagist3.2.5 ≤ v < 3.2.63.2.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-28105 · Phpmyfaq · Dark Radar