CVE-2024-28107
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.
How to fix
- phpmyfaq/phpmyfaq3.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpmyfaq phpmyfaq | 3.2.5 | — |
| phpmyfaq/phpmyfaqPackagist | 3.2.5 ≤ v < 3.2.6 | 3.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.