CVE-2024-28108
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Due to insufficient validation on the `contentLink` parameter, it is possible for unauthenticated users to inject HTML code to the page which might affect other users. _Also, requires that adding new FAQs is allowed for guests and that the admin doesn't check the content of a newly added FAQ._ This vulnerability is fixed in 3.2.6.
How to fix
- phpmyfaq/phpmyfaq3.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpmyfaq phpmyfaq | 3.2.5 | — |
| phpmyfaq/phpmyfaqPackagist | 3.2.5 ≤ v < 3.2.6 | 3.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.