CVE-2024-28148

Medium

Description

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Superset
PublishedMay 7, 2024
First seenMay 7, 2024

How to fix

Update
  • apache superset4.0.0 or later
  • apache-superset3.1.2 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.0.04.0.0
apache-supersetPyPIv < 3.1.23.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.