CVE-2024-29006
Critical
Description
By default the CloudStack management server honours the x-forwarded-for HTTP header and logs it as the source IP of an API request. This could lead to authentication bypass and other operational problems should an attacker decide to spoof their IP address this way. Users are recommended to upgrade to CloudStack version 4.18.1.1 or 4.19.0.1, which fixes this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Cloudstack
PublishedApr 4, 2024
First seenApr 4, 2024
Weakness typeCWE-290CWE-290
How to fix
Update
- apache cloudstack4.18.1.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cloudstack | 4.11.0.0 ≤ v < 4.18.1.1, 4.19.0.0 | 4.18.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.