CVE-2024-29034
Description
CarrierWave is a solution for file uploads for Rails, Sinatra and other Ruby web frameworks. The vulnerability CVE-2023-49090 wasn't fully addressed. This vulnerability is caused by the fact that when uploading to object storage, including Amazon S3, it is possible to set a Content-Type value that is interpreted by browsers to be different from what's allowed by `content_type_allowlist`, by providing multiple values separated by commas. This bypassed value can be used to cause XSS. Upgrade to 3.0.7 or 2.2.6.
How to fix
- carrierwave_project carrierwave2.2.6, 3.0.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| carrierwave_project carrierwave | v < 2.2.6, 3.0.0 ≤ v < 3.0.7 | 2.2.6, 3.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.