CVE-2024-29131

High

Description

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Commons Configuration
PublishedMar 21, 2024
First seenMar 21, 2024

How to fix

Update
  • apache commons_configuration2.10.1 or later
  • org.apache.commons:commons-configuration22.10.1 or later

Affected products

ProductAffected versionsFixed in
apache commons_configuration2.0 ≤ v < 2.10.12.10.1
fedoraproject fedora39, 40—
netapp ontap_tools10—
netapp snapcenterNo range specified—
org.apache.commons:commons-configuration2Maven2.0 ≤ v < 2.10.12.10.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.