CVE-2024-29217

Medium

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0. XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack. Users are recommended to upgrade to version [1.3.0], which fixes the issue.

SeverityMedium
CVSS4.6
Exploit probability—
ProductApache Answer
PublishedApr 21, 2024
First seenApr 21, 2024

How to fix

Update
  • apache answer1.3.0 or later
  • github.com/apache/incubator-answer1.3.0 or later

Affected products

ProductAffected versionsFixed in
apache answerv < 1.3.01.3.0
github.com/apache/incubator-answerGov < 1.3.01.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-29217 · Apache Answer · Dark Radar