CVE-2024-29733

Low

Description

Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

SeverityLow
CVSS2.7
Exploit probability—
ProductApache-airflow-providers-ftp
PublishedApr 21, 2024
First seenApr 21, 2024
Weakness typeCWE-295CWE-295

How to fix

Update
  • apache apache-airflow-providers-ftp3.7.0 or later
  • apache-airflow-providers-ftp3.7.0 or later

Affected products

ProductAffected versionsFixed in
apache apache-airflow-providers-ftpv < 3.7.03.7.0
apache-airflow-providers-ftpPyPIv < 3.7.03.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.