CVE-2024-29831

High

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server. If you are using the switch task plugin, please upgrade to version 3.2.2.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Dolphinscheduler
PublishedAug 12, 2024
First seenAug 12, 2024

How to fix

Update
  • apache dolphinscheduler3.2.2 or later
  • org.apache.dolphinscheduler:dolphinscheduler3.2.2 or later

Affected products

ProductAffected versionsFixed in
apache dolphinschedulerv < 3.2.23.2.2
org.apache.dolphinscheduler:dolphinschedulerMavenv < 3.2.23.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.