CVE-2024-30188
High
Description
File read and write vulnerability in Apache DolphinScheduler , authenticated users can illegally access additional resource files. This issue affects Apache DolphinScheduler: from 3.1.0 before 3.2.2. Users are recommended to upgrade to version 3.2.2, which fixes the issue.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Dolphinscheduler
PublishedAug 12, 2024
First seenAug 12, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache dolphinscheduler3.2.2 or later
- org.apache.dolphinscheduler:dolphinscheduler3.2.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache dolphinscheduler | 3.1.0 ≤ v < 3.2.2 | 3.2.2 |
| org.apache.dolphinscheduler:dolphinschedulerMaven | 3.1.0 ≤ v < 3.2.2 | 3.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.