CVE-2024-30261
Low
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. An attacker can alter the `integrity` option passed to `fetch()`, allowing `fetch()` to accept requests as valid even if they have been tampered. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
SeverityLow
CVSS2.6
Exploit probability—
Product
Nodejs Undici
PublishedApr 4, 2024
First seenApr 4, 2024
Weakness typeCWE-284Improper access control
How to fix
Update
- nodejs undici5.28.4, 6.11.1 or later
- undici5.28.4, 6.11.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nodejs undici | v < 5.28.4, 6.0.0 ≤ v < 6.11.1 | 5.28.4, 6.11.1 |
| fedoraproject fedora | 38, 39, 40 | — |
| undicinpm | v < 5.28.4, 6.0.0 ≤ v < 6.11.1 | 5.28.4, 6.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.