CVE-2024-30269

Medium

Description

DataEase, an open source data visualization and analysis tool, has a database configuration information exposure vulnerability prior to version 2.5.0. Visiting the `/de2api/engine/getEngine;.js` path via a browser reveals that the platform's database configuration is returned. The vulnerability has been fixed in v2.5.0. No known workarounds are available aside from upgrading.

SeverityMedium
CVSS5.3
Exploit probability—
ProductDataease
PublishedApr 8, 2024
First seenApr 8, 2024

How to fix

Update
  • dataease dataease2.5.0 or later

Affected products

ProductAffected versionsFixed in
dataease dataeasev < 2.5.02.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.