CVE-2024-3078

Medium

Description

A vulnerability was found in Qdrant up to 1.6.1/1.7.4/1.8.2 and classified as critical. This issue affects some unknown processing of the file lib/collection/src/collection/snapshots.rs of the component Full Snapshot REST API. The manipulation leads to path traversal. Upgrading to version 1.8.3 is able to address this issue. The patch is named 3ab5172e9c8f14fa1f7b24e7147eac74e2412b62. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-258611.

SeverityMedium
CVSS5.5
Exploit probability—
ProductQdrant
PublishedMar 29, 2024
First seenMar 29, 2024

How to fix

Affected products

ProductAffected versionsFixed in
qdrant qdrantv ≤ 1.6.1, 1.7.0 ≤ v ≤ 1.7.4, 1.8.0 ≤ v < 1.8.31.8.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.