CVE-2024-3104

Critical

Description

A remote code execution vulnerability exists in mintplex-labs/anything-llm due to improper handling of environment variables. Attackers can exploit this vulnerability by injecting arbitrary environment variables via the `POST /api/system/update-env` endpoint, which allows for the execution of arbitrary code on the host running anything-llm. The vulnerability is present in the latest version of anything-llm, with the latest commit identified as fde905aac1812b84066ff72e5f2f90b56d4c3a59. This issue has been fixed in version 1.0.0. Successful exploitation could lead to code execution on the host, enabling attackers to read and modify data accessible to the user running the service, potentially leading to a denial of service.

SeverityCritical
CVSS9.8
Exploit probability—
ProductMintplexlabs Anythingllm
PublishedJun 6, 2024
First seenJun 6, 2024

How to fix

Update
  • mintplexlabs anythingllm1.0.0 or later

Affected products

ProductAffected versionsFixed in
mintplexlabs anythingllmv < 1.0.01.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-3104 · Mintplexlabs Anythingllm · Dark Radar