CVE-2024-31211

Medium

Description

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

SeverityMedium
CVSS5.5
Exploit probability—
ProductWordpress
PublishedApr 4, 2024
First seenApr 4, 2024

How to fix

Update
  • wordpress wordpress6.4.2 or later

Affected products

ProductAffected versionsFixed in
wordpress wordpress6.4.0 ≤ v < 6.4.26.4.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-31211 · Wordpress · Dark Radar