CVE-2024-31449
Description
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- redis redis6.2.16, 7.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| redis redis | 2.8.18 ≤ v < 6.2.16, 7.2.0 ≤ v < 7.2.6, 7.4.0 | 6.2.16, 7.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.